23 coaches online • Server time: 05:21
Index Search Usergroups Profile
Log in
Recent Forum Topics goto Post AG5 for Underworld T...goto Post The Stunty Cup IIIgoto Post Revised apotechary
 
FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   ProfileProfile 
Post new topic   Reply to topic
View previous topic Log in to check your private messages View next topic
Grod



Joined: Sep 30, 2003
Location: Sydney, Australia

Post   Posted: May 04, 2011 - 14:27 Reply with quote Back to top

ultwe wrote:
ok, you could try this:

rename the javaws file to javaws-mod

create a new text file, named javaws, in the same folder as the original javaws file, with the following 2 lines:

unset -v GNOME_DESKTOP_SESSION_ID
./javaws-mod

save the file and make it executable

test

NOTE: on my Arch machine, javaws is found in /opt/java/jre/bin
NOTE: This is, at best, a dirty hack. You may want to add some comment to your text file, which explains what it does, and why it does it, if you need to be reminded a few years down the line. It may also break other programs. I did not test it myself.


Awesome it works! (at least running unset -v GNOME_DESKTOP_SESSION_ID before javaws).

Goodbye KDE!!! Thank heavens. Also you can just add a file javaws to your personal bin directory. Then make sure your browser opens the new javaws file when it is opening jnlp files instead of the other one. You may need to use a script that passes the filename argument?

In any case, running these commands from Gnome after I downloaded a game file to spectate works perfect:

unset -v GNOME_DESKTOP_SESSION_ID
javaws Downloads/ffb.jnlp

_________________
I am not young enough to know everything.

Oscar Wilde
Grod



Joined: Sep 30, 2003
Location: Sydney, Australia

Post   Posted: May 04, 2011 - 15:02 Reply with quote Back to top

OK do this to finally solve the problem under Gnome! This will work even if you upgrade java. You don't have to start a session under the evil KDE or any other crappy window manager.

* Open a terminal.
* Create a file in your /home/username/bin directory called "javaws_ffc".
* Edit the file and add the following lines:

#!/bin/bash
# This file is to play FFC under Gnome.
unset -v GNOME_DESKTOP_SESSION_ID
javaws $1

* Save and close the file. In the terminal type
chmod 755 javaws_ffc

* Open the file .bashrc located in your home directory with an editor.
* Make sure you have where you have defined your path an entry /home/username/bin
e.g. export PATH=.:/home/Grod/bin:$PATH
* Finally, we need to tell the system to open jnlp files with the new script. Download a jnlp file by clicking on a spectate link. Right click on file and select "properties". Select "Opens With", then "Add", "Use a Custom Command", then enter /home/user/javaws_ffc in the box. Add it. Then make sure it is selected in the list of applications to open ffb.jnlp.

You should be done.

_________________
I am not young enough to know everything.

Oscar Wilde
ultwe



Joined: Dec 25, 2004
Location: Edinburgh

Post   Posted: May 04, 2011 - 16:21 Reply with quote Back to top

The only thing with this (and what I suggested) is that it will affect all software that uses javaws, not just FFB. (not that I think there are that many of them that people use on a day to day basis)

_________________
Yeah, Nuffle sucks... That's because I play crap Smile

π is aproximately 3.142 times better than any other food
ultwe



Joined: Dec 25, 2004
Location: Edinburgh

Post   Posted: May 04, 2011 - 16:23 Reply with quote Back to top

Just thinking, has anyone tried FFB under Gnome3? did it have the same issue?

_________________
Yeah, Nuffle sucks... That's because I play crap Smile

π is aproximately 3.142 times better than any other food
Grod



Joined: Sep 30, 2003
Location: Sydney, Australia

Post   Posted: May 04, 2011 - 16:34 Reply with quote Back to top

ultwe wrote:
Just thinking, has anyone tried FFB under Gnome3? did it have the same issue?


Yes and yes.

_________________
I am not young enough to know everything.

Oscar Wilde
Grod



Joined: Sep 30, 2003
Location: Sydney, Australia

Post   Posted: May 04, 2011 - 16:38 Reply with quote Back to top

ultwe wrote:
The only thing with this (and what I suggested) is that it will affect all software that uses javaws, not just FFB. (not that I think there are that many of them that people use on a day to day basis)


True, although the way I did it, it will only affect the direct opening of jnlp files. Alternatively you could make the script a little more complicated, and make an if statement that checks if the jnlp file contains the characters "ffb" or not. Then only call the unset command if it does.

But I really don't think this will be an issue for many people.

Thanks for the idea in any case! /me is a happy Fumbbler now.

_________________
I am not young enough to know everything.

Oscar Wilde
ultwe



Joined: Dec 25, 2004
Location: Edinburgh

Post   Posted: May 04, 2011 - 16:44 Reply with quote Back to top

those peeps for whom it remains an issue can find their own solution(s) Wink

_________________
Yeah, Nuffle sucks... That's because I play crap Smile

π is aproximately 3.142 times better than any other food
Grod



Joined: Sep 30, 2003
Location: Sydney, Australia

Post   Posted: May 05, 2011 - 11:18 Reply with quote Back to top

I wrote up how do solve this problem in my blog. Note that if you are running firefox, you may also need to change the settings in firefox itself on which application it uses to open jnlp files. This has been added to my blog now.

http://fumbbl.com/FUMBBL.php?page=blog&coach=5203

_________________
I am not young enough to know everything.

Oscar Wilde
fabik



Joined: Aug 22, 2005
Location: Fagnano Olona

Post   Posted: May 06, 2011 - 17:49 Reply with quote Back to top

Simply.... I love YOU!

I think this solution should be Sticked
Nhero



Joined: Oct 15, 2006

Post   Posted: Nov 13, 2011 - 16:08 Reply with quote Back to top

Thanks mobo for the audio workaround!
truckerpunk



Joined: Dec 04, 2007

Post   Posted: Nov 13, 2011 - 17:12 Reply with quote Back to top

Anyone got the padsp / aoss script working on Ubuntu 11.10? I've been trying for a while now, and so far no luck. It used to be so easy.. =(. Now every sound the client plays, generates a new output in the sound preferences, and after a while it crashes (the sound, not the client).. All the audio streams are denoted "ALSA-plugin [java.bin]". To make sure it's clear my java script IS changed to a padsp wrapper.


Last edited by truckerpunk on Nov 13, 2011 - 22:10; edited 1 time in total
pythrr



Joined: Mar 07, 2006
Location: in a treee

Post   Posted: Nov 13, 2011 - 19:57 Reply with quote Back to top

since when has there been a gnome team?!

_________________
ImageImage
truckerpunk



Joined: Dec 04, 2007

Post   Posted: Nov 18, 2011 - 13:56 Reply with quote Back to top

A heads up for people running Linux. I've had a lot of trouble with java playing nicely with other sound apps, after I upgraded my distro, and Oracle java to the newest version (v 1.7.0u1). There seems to be a problem with this release, as well as the Openjdk 7, that causes the system to create a new audiostream for every sound the client plays. This eventually causes sound to crash due to overload. If you stick to Oracle java 6, and create the audio wrapper script, all should work fine.

Cheers!
Emeric



Joined: May 25, 2011
Location: France

Post   Posted: Nov 19, 2011 - 15:03 Reply with quote Back to top

Oh, missed that version 7 was out.
=> I just upgraded to openjdk7, that seems to work for now (but i only specced for some twenty minutes).
I'll check if i have the same issue than you in the next days.

_________________
Fill the BOX grid !
Francophone? #fumbbl.fr est là pour vous !
Emeric



Joined: May 25, 2011
Location: France

Post   Posted: Nov 20, 2011 - 13:38 Reply with quote Back to top

Here, openjdk7 works exactly as well as openjdk6 used to. No sound crash or bad behavior so far (played 3 games, spectated multiple games at the same time to give it a try).

At least with Archlinux, I'd recommend the upgrade Wink

_________________
Fill the BOX grid !
Francophone? #fumbbl.fr est là pour vous !
Display posts from previous:     
 Jump to:   
All times are GMT + 1 Hour
Post new topic   Reply to topic
View previous topic Log in to check your private messages View next topic
Powered by PNphpBB2 1.2 © 2003 PNphpBB Group
Credits