27 coaches online • Server time: 07:35
Index Search Usergroups Profile
Log in
Recent Forum Topics goto Post Is kicking first wit...goto Post Welcome Newcomers - ...goto Post Ghoul development
SearchSearch 
Post new topic   Reply to topic
View previous topic Log in to check your private messages View next topic
syghud



Joined: Apr 30, 2013

Post   Posted: Nov 26, 2013 - 13:45 Reply with quote Back to top

Thanks for your rapid answer.

I checked all that :

Quote:
root@Catwoman:/home/tiphaine# update-alternatives --config java
Il existe 4 choix pour l'alternative java (qui fournit /usr/bin/java).

Sélection Chemin Priorité État
------------------------------------------------------------
0 /opt/java-oracle/jdk1.7.0/bin/java 20000 mode automatique
1 /opt/java-oracle/jdk1.7.0/bin/java 20000 mode manuel
2 /usr/bin/gij-4.7 1047 mode manuel
* 3 /usr/java/latest/jre1.7.0_45/bin/java 1 mode manuel
4 /usr/lib/jvm/jdk1.7.0_45/bin/java 1062 mode manuel

Appuyez sur <Entrée> pour conserver la valeur par défaut[*] ou choisissez le numéro sélectionné :


And my iceweasel uses javaws as default ( /usr/java/latest/jre1.7.0_45/bin/javaws )

One more info : I can't close the FFBClient window once it's crashed. I've got to use a killall java to get rid of it.
truckerpunk



Joined: Dec 04, 2007

Post   Posted: Nov 26, 2013 - 13:55 Reply with quote Back to top

I'm still on Mint 15 here, so I'm a little lost.
Does Debian use pulseaudio, or ALSA, or something completely else for handling sound?

If possible, try and launch a spec game, go to the menu and turn off all sounds.
syghud



Joined: Apr 30, 2013

Post   Posted: Nov 26, 2013 - 14:50 Reply with quote Back to top

Don't know for sure but I think I'm on ALSA or pulseaudio, nothing really special.

I can't reach the menu, even in spec mode, I'm stuck with the info panel and can't do anything in the ffb window.
truckerpunk



Joined: Dec 04, 2007

Post   Posted: Nov 26, 2013 - 15:11 Reply with quote Back to top

I think it's running Pulseaudio. But I'm not sure if it has autospawn enabled as default. You could try a simple :

sudo killall pulseaudio

and see if the sound reboot automatically.. If not try to launch a game without pulseaudio running. This will help to narrow down the problem.
syghud



Joined: Apr 30, 2013

Post   Posted: Nov 30, 2013 - 15:03 Reply with quote Back to top

OK.

I deactivated pulseaudio autospawn
But even without pulseaudio running I can't get past the "About FFB Client" window.

So, well, the problem is narrowed down, but still here.

I really appreciate your help, truckerpunch
truckerpunk



Joined: Dec 04, 2007

Post   Posted: Nov 30, 2013 - 15:32 Reply with quote Back to top

Rather strange... I haven't seen this problem before. Usually people experience crashes or freezes after the "about"-screen. The only difference from our java setup seems to be that I run mine in "auto" mode:

There are 2 choices for the alternative java (providing /usr/bin/java).

Selection Path Priority Status
------------------------------------------------------------
* 0 /usr/lib/jvm/java-7-oracle/jre/bin/java 1074 auto mode
1 /usr/lib/jvm/java-7-openjdk-i386/jre/bin/java 1071 manual mode
2 /usr/lib/jvm/java-7-oracle/jre/bin/java 1074 manual mode

Press enter to keep the current choice[*], or type selection number:

But it dosen't seem like you have that option... And I doubt that should be the issue.

Perhaps try to purge all java from your system, and reinstall oracle java 1.7.45 again, to make sure that it's the only java avaliable, and it's not an intrenal error in the java itself?
truckerpunk



Joined: Dec 04, 2007

Post   Posted: Nov 30, 2013 - 15:36 Reply with quote Back to top

Hi again, mate. Try this way of setting up you java, the webupd8 guys usually know what they are doing.

http://www.webupd8.org/2012/06/how-to-install-oracle-java-7-in-debian.html

So purge your java and set up as described in the link. Fingers crossed. =)
syghud



Joined: Apr 30, 2013

Post   Posted: Nov 30, 2013 - 15:45 Reply with quote Back to top

Well, I'm don't know how to be sure to purge all java from my system, as I've followed many howtos and have quite a few javas hanging around.

But I think it lay be the source of my problem.
Any tip about purging my system ?

Thanks
truckerpunk



Joined: Dec 04, 2007

Post   Posted: Nov 30, 2013 - 15:58 Reply with quote Back to top

Try this:

sudo apt-get remove --purge java*

Still remember I'm not too familiar with Debian, but I believe this should work.
syghud



Joined: Apr 30, 2013

Post   Posted: Nov 30, 2013 - 16:03 Reply with quote Back to top

Hmmm...

it would have removed several programs like libreoffice or rythmbox, even nautilus-related packages so I'll try it a different way... and some other day.

I'll let you know.

Thanks again, mate
syghud



Joined: Apr 30, 2013

Post   Posted: Nov 30, 2013 - 16:37 Reply with quote Back to top

Ok, I finally tried it right now.

For those interested, I followed Eric Carvalho's instructions on this topic to uninstall all my java versions : http://askubuntu.com/questions/84483/how-to-completely-uninstall-java

Then I installed java as explained there : http://www.webupd8.org/2012/06/how-to-install-oracle-java-7-in-debian.html (thank you suckerpunch for the tip)

Now my updates-alternatives looks like this, clean and simple :

Quote:
root@Catwoman:/home/tiphaine# update-alternatives --config java
Il existe 1 choix pour l'alternative java (qui fournit /usr/bin/java).

Sélection Chemin Priorité État
------------------------------------------------------------
0 /usr/lib/jvm/java-7-oracle/jre/bin/java 1 mode automatique
* 1 /usr/lib/jvm/java-7-oracle/jre/bin/java 1 mode manuel

Appuyez sur <Entrée> pour conserver la valeur par défaut[*] ou choisissez le numéro sélectionné :


Then I configured Iceweasel to use the right javaws.

I restarted my PC just in case.

And I'm stuck with the same problem : Java runs, I've got the now infamous warning message and... I'm stuck on the "about" panel and can't access menus or even close the window without a "killall java"

I admit I'm puzzled.
truckerpunk



Joined: Dec 04, 2007

Post   Posted: Nov 30, 2013 - 16:53 Reply with quote Back to top

Grrr.. This is annoying. Java setup looks fine, as you say. You could swap to automatic mode just to give it a try, or try through another browser, though I doubt it will make a difference. But I'm running out of ideas here.

Perhaps save the fbb.jnlp file on your computer and launch with: javaws ffb.jnlp
syghud



Joined: Apr 30, 2013

Post   Posted: Nov 30, 2013 - 17:08 Reply with quote Back to top

I tried all (automatic mode, launching via terminal, and even installing chromium to try it via another browser), and I'm still at the same point, just a little more frustrated.

Well, I guess I'll use another PC to play.
syghud



Joined: Apr 30, 2013

Post   Posted: Feb 10, 2014 - 22:41 Reply with quote Back to top

OK.
I got an automatic update recently, so I just gave a try...

And now it works just fine...

It doesn't explain any of it but at least it works. Thanks for all your time, truckerpunk.
Panda_



Joined: Jul 14, 2004

Post   Posted: Feb 10, 2014 - 22:53 Reply with quote Back to top

syghud wrote:
OK.
I got an automatic update recently, so I just gave a try...

And now it works just fine...

It doesn't explain any of it but at least it works. Thanks for all your time, truckerpunk.


You' Talking about the sounds or the game with OpenJDK ?

_________________
"Rien ne sert de partir à point, il vaut mieux courir."
Display posts from previous:     
 Jump to:   
All times are GMT + 1 Hour
Post new topic   Reply to topic
View previous topic Log in to check your private messages View next topic
Powered by PNphpBB2 1.2 © 2003 PNphpBB Group
Credits