36 coaches online • Server time: 11:48
Index Search Usergroups Profile
Log in
Recent Forum Topics goto Post Break tackle Vs Stan...goto Post Guard vs MB on undea...goto Post Big Star Cauldron II...
SearchSearch 
Post new topic   Reply to topic
View previous topic Log in to check your private messages View next topic
fabik



Joined: Aug 22, 2005

Post   Posted: Jan 18, 2011 - 10:19 Reply with quote Back to top

Hi

It seams that if play with linux with sun java the client jams.
any suggestion?

Thanks a lot
Sinner



Joined: Aug 02, 2003

Post   Posted: Jan 18, 2011 - 10:28 Reply with quote Back to top

yes, unmute your audio. Also downgrade to 1.6.0_18

I had this freezing stuff too, till I downgraded and learned to unmute pulse or whatever you are using.

_________________
Sinner
Darkie's Dreams - successfully cherrypicking any race, any coach, any rating, any number of DP since 20/09/2003 ... and still winning!
truckerpunk



Joined: Dec 04, 2007

Post   Posted: Jan 18, 2011 - 10:42 Reply with quote Back to top

Jams, as in freeze or is it lagging? What distro are you running?
Grod



Joined: Sep 30, 2003

Post   Posted: Jan 18, 2011 - 10:44 Reply with quote Back to top

I have problems whenever I first connect to a game (playing or spectating) if the sound in the FFC is turned on in my personal settings, then my opened client will freeze. If I turn all the sounds in the FFC to off (before connecting), I don't have any problems. If I turn the sounds back on after I have connected, I don't seem to have problems. But it is such a weird bug it is difficult to trouble shoot to isolate it exactly.

I think what is happening is related to when you mute your system audio, and java throws an exception when the game tries to access it, which may not be caught properly by the client. However, I swear I have had problems when the system audio was not muted as well.

I am running the latest version of Ubuntu (Gnome).

_________________
I am so clever that sometimes I don't understand a single word of what I am saying.

Oscar Wilde
Grod



Joined: Sep 30, 2003

Post   Posted: Jan 18, 2011 - 10:55 Reply with quote Back to top

It may be something that only happens right at the very beginning of a game, when something is being initialised?

_________________
I am so clever that sometimes I don't understand a single word of what I am saying.

Oscar Wilde
Sinner



Joined: Aug 02, 2003

Post   Posted: Jan 18, 2011 - 11:05 Reply with quote Back to top

I tried the mute/unmute thing and it crashed a bit later.

I now play/spec in mute... not cool but better then crashing

_________________
Sinner
Darkie's Dreams - successfully cherrypicking any race, any coach, any rating, any number of DP since 20/09/2003 ... and still winning!
Grod



Joined: Sep 30, 2003

Post   Posted: Jan 18, 2011 - 11:10 Reply with quote Back to top

Yeah I am at work now, so I can't really test it out. At home I was also just playing with all the sounds off because it was guaranteed to work. At work I have OpenSUSE linux (Gnome), and just tried a variety of combinations of sounds on/off while spectating, but couldn't get it to crash...

I brought this up before to Lakrillo, but because I couldn't work out exactly when/how it was crashing, I didn't make a bug report.

[Edit:]

I brought it up in this post before:
http://fumbbl.com/index.php?name=PNphpBB2&file=viewtopic&p=443308&highlight=sound#443308

_________________
I am so clever that sometimes I don't understand a single word of what I am saying.

Oscar Wilde
Sinner



Joined: Aug 02, 2003

Post   Posted: Jan 18, 2011 - 11:23 Reply with quote Back to top

Okay,

I filed a bug report:
Bug report 597

Workaround:
start the client
before typing your password, go to 'user settings->sound->sound off'
connect
DO NOT TURN ON SOUND!

So far only reported on Ubuntu

_________________
Sinner
Darkie's Dreams - successfully cherrypicking any race, any coach, any rating, any number of DP since 20/09/2003 ... and still winning!
gandresch



Joined: Aug 02, 2003

Post   Posted: Jan 18, 2011 - 11:39 Reply with quote Back to top

I used Oracle Java 6 Update 23 with Ubuntu yesterday to spectate some games - with sound! The client doesn't crash.
Lakrillo



Joined: Sep 12, 2007

Post   Posted: Jan 18, 2011 - 11:58 Reply with quote Back to top

I suspect this might also be a driver-issue, test to update your drivers and java and report if that solved the problem.
Could you try to get us a stacktrace by having the Java console running when you crash?
Sinner



Joined: Aug 02, 2003

Post   Posted: Jan 18, 2011 - 12:09 Reply with quote Back to top

Hi Lakrillo, please refer to the bug 597 (linked above) I put a stack trace in there as well

_________________
Sinner
Darkie's Dreams - successfully cherrypicking any race, any coach, any rating, any number of DP since 20/09/2003 ... and still winning!
gandresch



Joined: Aug 02, 2003

Post   Posted: Jan 18, 2011 - 12:25 Reply with quote Back to top

Hi,

just tried with Ubuntu here at home (not at work). 2 weeks ago, the client worked perfectly and i didn't touch the system since that day. Now i tried again and the client crashed. I wasn't even able to mute the sound, because muting at start up didn't work.
I don't know, what has changed in the past weeks, but there has something changed. I cannot tell, why the Ubuntu at work works well, but i will check again in the following days.

Greets,
gan
truckerpunk



Joined: Dec 04, 2007

Post   Posted: Jan 18, 2011 - 12:37 Reply with quote Back to top

Hey. I'm running Ubuntu 10.04. I've always hated Pulseaudio, and have removed every trace of it, and dropped back to good old trusty ALSA. I have no problems what so ever spec'ing FFB games. I can't speak for playing, as I try to stick to LRB4 as long as possible. Another thing, I made a script that forces java applications to run through ALSA. With this setup I'm faciing no problems at all.

"How-to-make-script"-link: http://ohioloco.ubuntuforums.org/showthread.php?t=1568460

Might work with Pulse too. There's also directions for settting it up for pulse.
Hope it helps.
gandresch



Joined: Aug 02, 2003

Post   Posted: Jan 18, 2011 - 12:52 Reply with quote Back to top

It works!
Andreas



Joined: Nov 18, 2005

Post   Posted: Jan 18, 2011 - 12:52 Reply with quote Back to top

It may be pulseaudio hogging the sound device, making it unavailable for java. Try faking a device with padsp.

Edit /usr/bin/javaws with a text editor as root. The last line will look like this:

exec $(dirname $prog)/javaws.real "$@"

change it to this:

exec padsp $(dirname $prog)/javaws.real "$@"

This fix is only for webstart programs and you'll have to redo it every time java is updated.
Display posts from previous:     
 Jump to:   
All times are GMT + 1 Hour
Post new topic   Reply to topic
View previous topic Log in to check your private messages View next topic
Powered by PNphpBB2 1.2 © 2003 PNphpBB Group
Credits