12 coaches online • Server time: 03:19
Index Search Usergroups Profile
Log in
Recent Forum Topics goto Post pro option not given...goto Post NAF Zons built aroun...goto Post what next for an ag5...
Post new topic   Reply to topic
View previous topic Log in to check your private messages View next topic

Joined: Nov 06, 2013

Post   Posted: Apr 05, 2017 - 09:22 Reply with quote Back to top

I run Java 7 on a Ubuntu OS and have played my fair share of BB games here on FUMBBL but it seems like I cannot launch application now since the update. Details are as follows:

Error: Found unsigned entry in resource: https://fumbbl.com/FFBClient/live/FantasyFootballClient.jar

Launch File:
<jnlp spec="1.6+" codebase="https://fumbbl.com/FFBClient/live" href="/ffblive.jnlp?spectate=956477&c=Atari&a=RpJkdyTLnXrFsrJ8e%2FjDDph7cXAHNaPFczVJJUWJovx269qjTUyATrGSCif6chXh">
<update check="always" policy="always"/>
<jar href="FantasyFootballClient.jar"/>
<jar href="FantasyFootballClientResources.jar"/>
<jar href="org.osgi.core-4.3.0.jar"/>
<jar href="tinysound-1.1.1.jar"/>
<jar href="vorbisspi1.0.3.jar"/>
<jar href="jorbis-0.0.17.jar"/>
<jar href="tritonus_share.jar"/>
<j2se version="1.6" href="http://java.sun.com/products/autodl/j2se"/>
<j2se version="1.6+" href="http://java.sun.com/products/autodl/j2se"/>
<application-desc main-class="com.balancedbytes.games.ffb.client.FantasyFootballClient">


com.sun.deploy.net.JARSigningException: Found unsigned entry in resource: https://fumbbl.com/FFBClient/live/FantasyFootballClient.jar
at com.sun.javaws.security.SigningInfo.getCommonCodeSignersForJar(Unknown Source)
at com.sun.javaws.security.SigningInfo.check(Unknown Source)
at com.sun.javaws.security.JNLPSignedResourcesHelper.checkSignedResourcesHelper(Unknown Source)
at com.sun.javaws.security.JNLPSignedResourcesHelper.checkSignedResources(Unknown Source)
at com.sun.javaws.Launcher.prepareResources(Unknown Source)
at com.sun.javaws.Launcher.prepareAllResources(Unknown Source)
at com.sun.javaws.Launcher.prepareToLaunch(Unknown Source)
at com.sun.javaws.Launcher.prepareToLaunch(Unknown Source)
at com.sun.javaws.Launcher.launch(Unknown Source)
at com.sun.javaws.Main.launchApp(Unknown Source)
at com.sun.javaws.Main.continueInSecureThread(Unknown Source)
at com.sun.javaws.Main.access$000(Unknown Source)
at com.sun.javaws.Main$1.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

Any advice would be appreciated.



Enter your old and new teams to battle it out in divisional KO's to get a chance to take the light/middle or heavywieght divisions Sign UP

Joined: Aug 02, 2003

Post   Posted: Apr 05, 2017 - 11:27
Reply with quote Back to top

Update to the latest Java from Oracle. Currently, that's Java 8 update 121.

The error you're getting implies that you are lacking a root CA for the certificate used to sign the FFB Client. I'm not sure if the Linux version of Java uses a cetral OS certificate store, but you may need to add the root signing CA certificate to your system as well.

The certificate you need is the Comodo SHA-2 root. I won't link this as it's bad security practice to let other people give you certificates to install. Root CA certificates are quite powerful and installing a bad one can have pretty significant consequences. So you go look it up on your own instead if you end up needing it.

Joined: Nov 06, 2013

Post   Posted: Apr 06, 2017 - 02:45 Reply with quote Back to top

Thanks Christer. Have installed Oracle Java and it worked with embedded java code on websites however, I tried to use it on FUMBBL but couldn't get it to interact with the web interface of the FFB client and only advice I could find was to revert back to javaw with the OpenJDK/IcedTea v8. Am having errors with that as well after a full uninstall of all java files and fresh reinstall. (won't load FFB client and has security errors on Java testing site)

Seems to be a problem with security settings but I lack the knowledge to edit the security documents correctly to fix the error (though I have had a look through them). Have spent 5 hours on it the morning but may just wait until I get a computer upgrade, this one is starting to struggle a bit and my knowledge is pretty limited with coding.

If you know how to run a java web interface with Oracle I know I can install that and make it work, enabling firefox to identify it and pass test on javas website but cannot load FUMBBL. Your a busy man, I know, so don't go out of your way just point me in the right direction if it is convenient!

Thanks again

Joined: Aug 02, 2003

Post   Posted: Apr 06, 2017 - 14:30
Reply with quote Back to top

FFB is not going to work properly with OpenJDK/IcedTea. You really do need Oracle's implementation for it to work properly.

You need to make sure your browser loads the jnlp files you download from the site with the javaws executable (note the S on the end, it's important).

But as I said, you may need to update your CA certificate store. With a recent Ubuntu version, that shouldn't be necessary but I have a feeling your machine may have an old release of that as well.

While I do use Ubuntu myself, it's only in a server context. I haven't used linux on the desktop for many many years and it's therefore very hard for me to support your particular setup. Even if I did run Ubuntu on the desktop I'd be running the latest release which you may not be using. While you have a lot of power when running Linux, it's a huge threshold to dive in to what happens behind the scenes.

Either way, my only real recommendation here is to update your Ubuntu to the latest release and make sure you're on Oracle's Java implementation. Security stuff is really hard in general, and without direct access to the machine, I can't help much. It's simply too much stuff that could be wrong and I don't have first-hand experience with desktop Linux in general.

Joined: Nov 06, 2013

Post   Posted: Apr 07, 2017 - 03:59 Reply with quote Back to top

Ok, will be able to figure that out. Will update my linux to 16 and hopefully that will solve the issue. I will be able to troubleshoot getting the javaws executable to load I am sure and will switch back to Oracle and will figure out where it has javaws exe as I could only find it in the OpenJDK/IcedT version.

Thanks again for your time Christer, will try my best!
Display posts from previous:     
 Jump to:   
All times are GMT + 1 Hour
Post new topic   Reply to topic
View previous topic Log in to check your private messages View next topic