58 coaches online • Server time: 17:44
Index Search Usergroups Profile
Log in
Recent Forum Topics goto Post CR system math detai...goto Post Is dirty player wort...goto Post java
SearchSearch 
Post new topic   Reply to topic
View previous topic Log in to check your private messages View next topic
darkjul



Joined: Mar 12, 2013

Post   Posted: Mar 26, 2015 - 15:25 Reply with quote Back to top

I use Ubuntu 12.04 ... I try window option on ccsm with no effect so I remove that variable ... So I ask you step by step instructions in order to avoid breaks ...
Kam



Joined: Nov 06, 2012

Post   Posted: Mar 26, 2015 - 15:30 Reply with quote Back to top

Do you use the Gnome session or the Unity session? It won't work in the first case...

EDIT - If you don't understand what I'm talking about, could you please paste this into a terminal and copy the output?

Code:
echo $XDG_CURRENT_DESKTOP

_________________
GLN 17 is out!
Image
darkjul



Joined: Mar 12, 2013

Post   Posted: Mar 26, 2015 - 19:36 Reply with quote Back to top

Kam wrote:
Do you use the Gnome session or the Unity session? It won't work in the first case...

EDIT - If you don't understand what I'm talking about, could you please paste this into a terminal and copy the output?

Code:
echo $XDG_CURRENT_DESKTOP
Unity
Kam



Joined: Nov 06, 2012

Post   Posted: Mar 26, 2015 - 20:02 Reply with quote Back to top

OK then, open a BB game.

Open ccsm, tick the Window Rules plugin. Navigate to the Size Rules tab. Click on the "New" button. Click on the "+" icon in the pop up window. Select "Window class" in the drop-down menu. Click on the "input" button or whatever it's called in English - your cursor will turn into a cross. Click on FUMBBL window (use ALT+TAB to raise it if needed - do NOT try to raise it by clicking on its icon in the apps tray), and then on the "add" button. Select 1014 and 780 respectively for the width and the height. Click the close button. That's it.

https://www.dropbox.com/s/9okclw96qp5nvxe/Capture%20du%202015-03-26%2020%3A09%3A22.png?dl=0

I can't make a more detailed explanation. Very Happy

Note: the changes should be applied immediately. If that's not the case, try reloging (or type "compiz --replace" in a terminal).

_________________
GLN 17 is out!
Image
darkjul



Joined: Mar 12, 2013

Post   Posted: Mar 26, 2015 - 20:41 Reply with quote Back to top

I did it ... Tnx
JMkiller



Joined: Jun 26, 2013

Post   Posted: Apr 06, 2015 - 17:35 Reply with quote Back to top

new to ubuntu.... how to find window rules in ccsm? +

_________________
“Two possibilities exist: either we are alone in the Universe or we are not. Both are equally terrifying.”
? Arthur C. Clarke
JMkiller



Joined: Jun 26, 2013

Post   Posted: Apr 06, 2015 - 17:43 Reply with quote Back to top

sudo apt-get install compiz-plugins

_________________
“Two possibilities exist: either we are alone in the Universe or we are not. Both are equally terrifying.”
? Arthur C. Clarke
Kam



Joined: Nov 06, 2012

Post   Posted: Apr 06, 2015 - 22:16 Reply with quote Back to top

I will make a wiki page on Linux when I have some time to spare so the info isn't diluted.

I just wanna fix that damn pulseaudio first so it doesn't burn your CPU when resampling the game sounds on some systems - I have a clue but... it's gonna require more testing.

_________________
GLN 17 is out!
Image
SteamBall



Joined: Nov 09, 2010

Post 3 Posted: Jan 06, 2016 - 00:25 Reply with quote Back to top

For when the wiki page comes true:

Situation: Linux, ALSA with dmix enabled (so multiple properly coded programs can output sound at the same time) and OSS compatibility (for the old ones), Oracle JRE. Client launched via "javaws ffblive.jnlp". A similar setup was working fine years ago, using "aoss javaws ffblive.jnlp". Confused

Problem: If there is something using the soundcard, client goes mute. If client can get the soundcard first, nothing else can use the soundcard until client is closed. No matter if "javaws" or "aoss javaws", it's one client or the rest of apps, but not all at the same time. Mad

Solution: find where is the libjsoundalsa.so file from the JRE (it should be in same place than libjsound.so, start with "find /usr/lib/ -name libjsoundalsa.so" or use the package manager), rename as root (or sudo, or whatever) to something else like "mv libjsoundalsa.so libjsoundalsa.so-disabled". Then java will stop using it's poorly implemented code for ALSA and fall back to the OSS version. Launch with "aoss javaws ffblive.jnlp". Now all programs can play sounds at the same time, including multiple java programs. Very Happy
arie_papa



Joined: Dec 31, 2015

Post   Posted: Jan 19, 2016 - 19:17 Reply with quote Back to top

I'm running Ubuntu 15.10 64bit with Oracle Java 8 JRE.
The FFB client starts and I can play games, but the borders for the example inputfield chat isn't shown.
A link to a screenshot to make it more clear.
https://www.dropbox.com/s/dp9grjhoa3n8lrh/FFBL_Ubuntu15.10_OracleJava8.png?dl=0


On my Raspberry Pi running Raspbian Jessie with the icedtea-7-plugin the FFB client shows the normal behaviour, so I'm a bit confused (only watched a game, didn't play yet on the RPi).

Anyone with a solution for this problem on my Ubuntu machine? The chat itselfs works, but I can't see what I have typed before pressing enter, so it is a bit anoying.
Tarabaralla



Joined: Jul 24, 2010

Post   Posted: Jan 28, 2016 - 09:32 Reply with quote Back to top

Kam wrote:
OK then, open a BB game.

Open ccsm, tick the Window Rules plugin. Navigate to the Size Rules tab. Click on the "New" button. Click on the "+" icon in the pop up window. Select "Window class" in the drop-down menu. Click on the "input" button or whatever it's called in English - your cursor will turn into a cross. Click on FUMBBL window (use ALT+TAB to raise it if needed - do NOT try to raise it by clicking on its icon in the apps tray), and then on the "add" button. Select 1014 and 780 respectively for the width and the height. Click the close button. That's it.

https://www.dropbox.com/s/9okclw96qp5nvxe/Capture%20du%202015-03-26%2020%3A09%3A22.png?dl=0

I can't make a more detailed explanation. Very Happy

Note: the changes should be applied immediately. If that's not the case, try reloging (or type "compiz --replace" in a terminal).


Perfect description! I'd just add to click on the "Enable windows rules" option in ccsm, which I didn't at the first time Very Happy

EDIT: now I see that "tick the windows rules plugin"... missed it!
iipepeii



Joined: Jun 29, 2010

Post   Posted: Oct 19, 2016 - 22:54 Reply with quote Back to top

Hi! I'm new at Linux(Ubuntu). How can I play at FUMBBL? I have openjdk 8 on my machine, I downloaded a .jpnl, cause I wanted to spectate, but something expectation error happened. Please help me!

(I downloaded the file, then tried this: sudo javac ffblive.jpnl - The output was this: Class names, 'ffblive.jpnl', are only accepted if annotation processing is explicitly requested
1 error

_________________
My blog with some BB posts(hungarian): http://pepesgamecorner.blog.hu/
Display posts from previous:     
 Jump to:   
All times are GMT + 1 Hour
Post new topic   Reply to topic
View previous topic Log in to check your private messages View next topic
Powered by PNphpBB2 1.2 © 2003 PNphpBB Group
Credits