62 coaches online • Server time: 18:04
Index Search Usergroups Profile
Log in
Recent Forum Topics goto Post ALTDORF COLLEGE OF M...goto Post Welcome Newcomers - ...goto Post Dark Elf runners yay...
SearchSearch 
Post new topic   Reply to topic
View previous topic Log in to check your private messages View next topic
Danishcitizen



Joined: Sep 04, 2015

Post   Posted: Nov 20, 2015 - 08:12 Reply with quote Back to top

Java have blocked my laucher and i dont know how to fix that. So uhmmm help.
Christer



Joined: Aug 02, 2003

Post   Posted: Nov 20, 2015 - 12:33
FUMBBL Staff
Reply with quote Back to top

Hi,

I'm getting other reports of this problem as well.

The reason this is happening is that at 00:59:59 this morning (server time), the code signing certificate used to sign the FFB client expired. For most people, Java ignores this (rightly so; at the time of the signature, the certificate was valid) but apparently some configurations will prevent the client from starting.

I am not entirely sure exactly what setting this is, and it certainly works fine for most people.

I have tested the latest version of Java (1.8.0_66) for Windows (specifically Win8.1) and can get past an initial warning (with a checkbox allowing me to remember the permission to run the app). I suggest the following procedure to get properly up to date and potentially let you get things to work again:

1. Download and install the latest verion of Java. Currently, this is 1.8.0 update 66. Remember to not let it change browser settings to avoid annoyances.
2. Open the Java control panel (Control Panel->Java)
3. In the "General" tab, click the "View" button under Temporary Internet Files
4. Click on FantasyFootballClient and then the "remove" button (big red cross). Repeat until there are no further references to FantasyFootballClient
5. Click the Close button and then the "Network Settings" button
6. Select "Direct Connection", and press OK.
7. Switch to the "Java" tab and click the "View" button
8. Make sure that the only enabled product is the newly installed one (in this case 1.8.0_66). This goes for both the User and the System tabs.
9. Click OK and switch to the "Security" tab.
10. Select the "High" security level
11. Under Exception Site List, click the "Edit Site List..." button.
12. Make sure http://fumbbl.com, https://fumbbl.com and https://fumbbl.com/ffblive.jnlp are in the list
13. If not, Click the "Add" button and add the three entries. Note that the dialog will warn about the http version. This is fine.
14. Click OK and click on the "Restore Security Prompts" button.
15. Click "Restore All"
16. Click OK and switch to the Advanced tab
17. Under "Execution Environment Security Settings, ensure the following options are enabled:
- Allow user to grant permissions to signed content
- Allow user to accept JNLP security requests
18. Under "Mixed code (sandboxed vs. trusted) security verification, make sure this is NOT disabled (I recommend "Enable - show warning if needed)
19. For revocation settings (the next few sections), I recommend the following:
- All certificates in the chain of trust
- Both CRLs and OCSP
(these are set in two sections each)
20. Under Advanced Security Settings, make sure that "Enable the operating system's restricted environment (native sandbox)" is OFF.
21. Under Miscellaneous, enable "Suppress sponsor offers when installing or updating Java".
22. Smile at the fact that the option in step 21 is at the very bottom of an "Advanced" list.
23. Click OK, and accept the UAC request to change Java
24. Close the control panel

Now, go try to spectate a match. You will get a dialog asking if "you want to run this application". Click the "I accept" checkbox, click "Show Options", enable "Do not show this again for apps from the publisher and location above". Then click "Run".

At this point, the FFB client should launch. It may give you a wrong password prompt if it took a while to download and allow the application to start. Simply close the client and relaunch it to fix this.

If this process does not work, please try another browser and let me know.

Either way, I will be looking into updating my code signing certificate (Yay for yearly $100 expenses to remove warning messages), but this will unfortunately take some time to sort out.


Last edited by Christer on Nov 20, 2015 - 20:23; edited 2 times in total
Cyrus-Havoc



Joined: Sep 15, 2006

Post   Posted: Nov 20, 2015 - 17:24 Reply with quote Back to top

This worked for me thanks.

_________________
Not Undead but perhaps the oldest living coach!
Mr_Foulscumm



Joined: Mar 05, 2005

Post   Posted: Nov 20, 2015 - 17:36 Reply with quote Back to top

Those steps didn't work on their own for me, until I also added: https://fumbbl.com/ffblive.jnlp to the Exceptions List as well. Just figured I'd share in case someone has more trouble.

_________________
Everybody's favorite coach on FUMBBL
babass



Joined: Apr 20, 2013

Post   Posted: Nov 20, 2015 - 17:42 Reply with quote Back to top

new security settings were too strict within java !

i upgrade it
it was not enought.

i had to add https://fumbbl.com in the "exception" url of applications... in the "security" tab of the config panel of java)
FRSHMN



Joined: Feb 25, 2013

Post   Posted: Nov 20, 2015 - 18:28 Reply with quote Back to top

Christer wrote:

22. Smile at the fact that the option in step 21 is at the very bottom of an "Advanced" list.


I did! Very Happy

Thanks for sorting this out.
PainState



Joined: Apr 04, 2007

Post   Posted: Nov 20, 2015 - 19:26 Reply with quote Back to top

I did not update my Java, I will at some point here in the next few days/months/years.

What I dis was go into Java and put the URL of FUMBBL in my exempt list and everything was fine after that. You can find that under the security tag on the JAVA configuration.

_________________
Comish of the: Image
Quinze



Joined: Apr 05, 2013

Post   Posted: Nov 20, 2015 - 19:51 Reply with quote Back to top

I got this working by adding an exception for "https://fumbbl.com/ffblive.jnlp" (including the application name itself), but Christer's method is probably more comprehensive.
Christer



Joined: Aug 02, 2003

Post   Posted: Nov 20, 2015 - 20:24
FUMBBL Staff
Reply with quote Back to top

Updated both this post and the front-page news entry with the additional exception entry. Thanks!
Throweck



Joined: Feb 23, 2013

Post   Posted: Nov 20, 2015 - 20:29 Reply with quote Back to top

This worked for me Christer. Thank you very much, Legend.
Kalamona



Joined: Apr 21, 2005

Post   Posted: Nov 20, 2015 - 21:00 Reply with quote Back to top

i have done everything as above, but when i wanted to add to the exception site list the add button grayed out. tried to run it as an administrator, but its the same. removed java, installed it back... same. any idea?
Throweck



Joined: Feb 23, 2013

Post   Posted: Nov 20, 2015 - 21:19 Reply with quote Back to top

Mine greyed out until I clicked on the typy box thing, then I could type in it.
Kalamona



Joined: Apr 21, 2005

Post   Posted: Nov 20, 2015 - 21:28 Reply with quote Back to top

i cant type in it and says click add to add an item, but the add button wont light up.
Kalamona



Joined: Apr 21, 2005

Post   Posted: Nov 20, 2015 - 21:49 Reply with quote Back to top

sorted. needed to remove current java and had to install java 7 lower security to medium and i was able to amend the list.
Matthueycamo



Joined: May 16, 2014

Post   Posted: Nov 20, 2015 - 22:09 Reply with quote Back to top

I just changed the Java security to medium, so instead of auto denying the client it warns you and gives you the option to proceed anyway. Seemed the easiest way.

_________________
Image

DLE College 7s
Display posts from previous:     
 Jump to:   
All times are GMT + 1 Hour
Post new topic   Reply to topic
View previous topic Log in to check your private messages View next topic
Powered by PNphpBB2 1.2 © 2003 PNphpBB Group
Credits