42 coaches online • Server time: 09:05
Index Search Usergroups Profile
Log in
Recent Forum Topics goto Post Cyanidegoto Post 6+6 for welf catchergoto Post Playing Dwarves...
 
FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   ProfileProfile 
Post new topic   Reply to topic
View previous topic Log in to check your private messages View next topic
arw



Joined: Jan 07, 2007

Post   Posted: Apr 26, 2015 - 22:47 Reply with quote Back to top

Hello guys, since I am ignorant of both Fedora and Java I can't get FFB to start.

In fact it is a pitiful thing that presents itself as an insurmountable obstacle: the program file needed to run ffblive.jnlp is nowhere to be found. At least I hope that's the problem...

Java should be properly installed. I ran the terminal to use yum: "yum install java". It did install Java as far as I can tell. Now I got a bunch of java stuff here & there and tried several if not all java related program files to open the ffblive.jnlp yet it did not work. No error message, no reaction. The "java" file in /usr/lib/jvm/jre/bin seemed most promising. Now I am not sure whether or not I need to install something else. Usually the webstarter should be included but since I don't know Fedora & Java details I am not too sure about anything.

The terminal knows java and I tried to open the .jnlp "manually" in the terminal. Typing "java ffblive.jnlp" gave a reply: "Fehler: Hauptklasse jnlp konnte nicht gefunden oder geladen werden" (german... translates: "Error: main class jnlp could neither be found nor loaded").

I'd really appreciate any kind of help.
Kam



Joined: Nov 06, 2012

Post   Posted: Apr 26, 2015 - 22:51 Reply with quote Back to top

It's Java Web Start, not Java. Check if you have a javaws binary in /usr/bin. If not, install Iceadtea or Oracle's javaws.

Also, you may wanna do a:

Code:
sudo update-alternatives --config javaws


to make sure you're using the right package.

I can't help much beyond this point, I'm not familiar with Fedora.

_________________
GLN 15 is out!
Image
arw



Joined: Jan 07, 2007

Post   Posted: Apr 26, 2015 - 22:59 Reply with quote Back to top

That's already quite helpful - now I know what I need to check on!

PS: Problem solved!
Just installed javaws (or rather icedtea) and it worked right away. You helped me plenty Kam - thank you!
Display posts from previous:     
 Jump to:   
All times are GMT + 1 Hour
Post new topic   Reply to topic
View previous topic Log in to check your private messages View next topic
Powered by PNphpBB2 1.2 © 2003 PNphpBB Group
Credits