18 coaches online • Server time: 06:22
Index Search Usergroups Profile
Log in
Recent Forum Topics goto Post Crowd funded teams &...goto Post The Jalapeño Popp...goto Post SWL Fringe Tourneys
SearchSearch 
Post new topic   Reply to topic
View previous topic Log in to check your private messages View next topic
RedPuma



Joined: Jun 25, 2014

Post   Posted: Jan 12, 2015 - 09:33 Reply with quote Back to top

Hey everybody,
I recently updated my laptop from Ubuntu 14.04 to 14.10. In the old version, I managed to get the client to run; not very reliably and with all the known issues (white bar at the bottom, sound problems etc.), but since the update it won't work at all. I downloaded java (using the tips on this site:http://ubuntuhandbook.org/index.php/2014/09/install-oracle-java-ubuntu-1410/) but still, no luck. When I try to spectate a game, I get the 'open with/ save file' window, but can only choose firefox as an option (when it should say java of some sort).
I also already tried Chrome since there seem to be some issues with Linux-java-and firefox, but that didn't work either.
Any ideas that could help this n00b out?
albinv



Joined: Sep 15, 2012

Post   Posted: Jan 16, 2015 - 11:12 Reply with quote Back to top

Being incompetent with computers for years i can tell you it could be almost anything. But most most probably its Java that wasnt deleted and/or installed properly during the update routine.

Manually (console!) get rid of all java ("remove -purge" it is i think) and reinstall oracle java by console.

Dont use openjava and icedtea it will only work for 0,5 % of people i think (speaking of FFB).

Also Ubuntus update routine always caused issues - last time i had a peak was about 2-3 years where they stated it got better but that its still preferable to just install the new ubuntu version. Not sure. Can only confirm that ubuntus update system always caused issues for me.

Once again: do all java installation/ deinstallation stuff by console only! Graphical tools still cause problems here and there on a regular.
albinv



Joined: Sep 15, 2012

Post   Posted: Jan 16, 2015 - 11:17 Reply with quote Back to top

Get rid of all previous java (!!), make sure it got removed, reinstall oracle java, make sure its the java used by the system and got "registered".

All by those console commands i always forget (somehow thank god).

Edit: as much as i hate to say it, if that didnt do it: forget about ubuntus update routine and just do a fresh install of the new ubuntu version. Cause all sorts of things might have got messed up here (dependencies not being resolved properly) and will continue to be messed up.

Ubuntus update system isnt safe (most people will never realize it cause they still get a "working system"). I changed to a different distro due to it. If you want a stable ubuntu linux - fresh install new versions from now on. Period.
RedPuma



Joined: Jun 25, 2014

Post   Posted: Jan 22, 2015 - 12:01 Reply with quote Back to top

Thank you, albinv. I removed everything and installed oracle (again), but somehow the installation always fails (or rather: the installation seems to be going fine, but my system doesn't seem to 'register' it). Did that three times now, still won't work. I guess I'll just make do without it for a while, perhaps it works better with the next Ubuntu version. Thanks for your help though!
Also, I did a clean install of 14.10, not an update. I have had some issues with the normal update function before, too Wink
kutte



Joined: Aug 05, 2008

Post   Posted: Jul 11, 2015 - 12:30 Reply with quote Back to top

I know that with a thread this old posting is borderline necromancy, but as I just randomly stumbled on it and think I know what's wrong, I'll just do it anyways Razz

It seems that the only problem is telling your Firefox to hand that file (assuming you mean the .jnlp) over to Java Webstart. There are two ways to achieve this.

1- In the dialogue, just save the file somewhere. Then go to that directory with your file manager and try right-clicking on the ffblive.jnlp if your Java installation worked, there should be an option to open it with Java Web Start.

2- In the dialogue, choose manually set the program to open the file with, click Browse, go to /usr/lib/jvm/java-7-oracle/jre/bin and select javaws. Check the mark for doing this for all files of this type in the future to save you the hassle.

Apart from the other issues (white border, sounds), it should be working fine.

Tested with Oracle Java 7 on elementary OS Freya (based on Ubuntu 14.04).
Display posts from previous:     
 Jump to:   
All times are GMT + 1 Hour
Post new topic   Reply to topic
View previous topic Log in to check your private messages View next topic
Powered by PNphpBB2 1.2 © 2003 PNphpBB Group
Credits